for i, Development Editor for the iPad
for i, Available on the App Store
Requires iPad with OS version 3.2 or greater

Supported Languages

  • Plain text files
  • ActionScript 3 (as of version 1.0.2)
  • Assembler - x86, MIPS
  • ASP - VB, JavaScript
  • ASP.Net - C#, VB
  • Applescript
  • C
  • C++
  • C#
  • ColdFusion (as of version 1.0.2)
  • CSS
  • HTML
  • Javascript
  • Latex
  • Lisp
  • Objective-C
  • Perl
  • PHP
  • Python
  • Ruby
  • SQL - Standard, MySQL
  • Visual Basic
  • XML, including PList


We're working on improving the implementation of these languages, plus the ability to import TextMate bundles.